psychopy.org | Reference | Downloads | Github

Trouble Running Psychopy - Crash when Opening - wxAssertionError?

error2

Windows 10

After uninstalling and reinstalling a fresh copy of psychopy (because I was trying to figure out how to make Spyder know about psychopy),

When clicking on psychopyApp.py or running the icon from the start menu,
this black window opens and quickly closes. The picture is a screenshot before it disappeared.

I’ve looked at the troubleshooting information on psychopy.org, but I could not find appData.cfg or userPrefs.cfg existing. I’ve also used the reset option to erase all my files and have the OS reinstalled.

I’ve also tried installing the most recent standalone versions as well as up to 3 versions below it (uninstalling and using ccleaner each time). I’ve also tried downloading zip files, extracting, and double clicking on the psychopyApp.py

I appreciate any help. This problem is something I have tried looking up and fixing these past two days. Thank you!

That’s an interesting one that I’ve not encountered before. It seems your system doesn’t have a default code font defined. I wonder what happens if you replace the line

self._codeFont = wx.SystemSettings.GetFont(wx.SYS_ANSI_FIXED_FONT)

with

self._codeFont = wx.Font(self._mainFont.GetPointSize(), wx.FONTFAMILY_MODERN, wx.FONTSTYLE_NORMAL, wx.FONTWEIGHT_NORMAL)

?
The idea is to try and replace the “system standard” code font with a “generic” code font.

Hello @jon - a great thank you for the recommendation.

How odd! After the change, a black window popped up and the cursor blinked for a relatively odd length of time before the windows did appear. I noticed that the coder’s output window started downloading something, but failed to finished.

I am not sure what this message means - and if I need to do something else to minimize errors.

After quitting and opening a few times, it was actually trying to get me to download ffmpeg-win32-v3.2.4.exe

After uninstalling and installing the current beta 9 standalone version, everything is okay!