psychopy.org | Reference | Downloads | Github

TextBox cann't work----freetype.ft_errors

Hello~
I am having trouble with the use of ‘TextBox’ to show text stimuli .The error message shows as below:
‘’’
File “F:\ResearchSoftwares\PsychoPy3\lib\site-packages\freetype_init_.py”, line 989, in init
if error: raise FT_Exception( error )
freetype.ft_errors.FT_Exception: FT_Exception: (cannot open resource)
‘’’
The version I download is windows- psychopy-v3.03-Standard-Standalone .And I find the demo cannot work either.
I tried a lot of solutions introduced online,but they didn’t work.
Can someone tell me how to solve this problem? Many many thanks!

Same here (3.03, OsX):

"Traceback (most recent call last):
File “freetype/raw.pyc”, line 49, in
File “ctypes/init.pyc”, line 348, in init
OSError: dlopen(libfreetype.dylib, 6): image not found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/demos/coder/stimuli/textBoxStim/textstim_vs_textbox.py”, line 25, in
from psychopy.visual import textbox
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/visual/textbox/init.py”, line 37, in
from .fontmanager import FontManager
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/visual/textbox/fontmanager.py”, line 21, in
from freetype import Face, FT_LOAD_RENDER, FT_LOAD_FORCE_AUTOHINT, FT_Exception
File “”, line 961, in _find_and_load
File “”, line 950, in _find_and_load_unlocked
File “”, line 646, in _load_unlocked
File “”, line 616, in _load_backward_compatible
File “freetype/init.pyc”, line 21, in
File “”, line 961, in _find_and_load
File “”, line 950, in _find_and_load_unlocked
File “”, line 646, in _load_unlocked
File “”, line 616, in _load_backward_compatible
File “freetype/raw.pyc”, line 52, in
RuntimeError: Freetype library not found"

I am also experiencing the same issues with PsychoPy3 on my Mac…

Update:

I tried installing FreeType following these instructions which updates the error to:

I’m unsure whether that’s getting closer to the solution or not though…

I’ll have to look into the packaging to see if we can package freetype (or maybe it is being packaged but not detected) but in the meantime could you try installing freetype on the mac using homebrew?

brew install freetype