psychopy.org | Reference | Downloads | Github

“Take a break” works on psychopy but not in pavlovia

Hi,
I tried to insert a break after every 60 trials.The following lines were added :slight_smile:

This works perfectly when PsychoPy runs off the local computer. But when tested online, the break does not appear.
So my different lists (60 stimuli per list) keep scrolling without a break. I know there are often translation problems between python and java, but I have no idea how to make the break appear on pavlovia.

Thanks for any help or ideas.

thisN and thisTrialN doesn’t work online. You need to set up your own counter.

loopIdx=-1

loopIdx+=1

if loopIdx == 59:

Thank you for your answer, i tried your solution but now i have a break between each stimulus. Do you know why?

Probably because I missed the not

Try if loopId != 59:

I’m hoping that you realised that loopIdx=-1 should go in Begin Experiment not in the same place as the other two lines.

Hi
I have the same issue, please could you paste the answer, how the final code will look like along with other settings?