Survey upload error: SyntaxError: Unexpected token '<', "

Hi, I’m running an online experiment via Pavlovia that includes an embedded Pavlovia Survey at the end. A participant just emailed me saying that after completing the survey they received the following error message (image attached), which apparently stopped Pavlovia from uploading any of their data from the session.

Unfortunately we encountered the following error:

  • when uploading the survey response for experiment: XXXXX and survey: XXXX
  • SyntaxError: Unexpected token ‘<’, "

About 50 participants have previously completed the experiment and survey successfully, and the code has not changed recently.
If I’m reading the message correctly, it indicates it’s a problem with the survey bit (which ~50 participants have previously completed successfully). I am guessing that it may relate to the participant’s input in a free-response text box; maybe they used a special character in their response that some script behind the scenes did not like? I noticed that the Pavlovia Surveys web GUI contains options for validating responses (which would be my first thought), but these do not seem to be documented anywhere.

This doesn’t seem to be a common problem even with this survey, but I’d really like to avoid losing any more data. Any idea what the problem could be and how to address it?

Are you able to see if you can recreate the error by entering < and > into your free text box?

No, I’ve tried that. Also tried < < \< “<” “\<” “<” ‘<’. Actually tried entering many/all of the non-alphanumeric symbols that are on my US keyboard. No errors from any of these, at least when I tried entering them when accessing the survey directly (i.e., not embedded in the experiment). The embedded survey (linked via id in Builder) comes after a ~500 trial experimental loop, so I’ve not been re-testing it in-situ.