Stuck at initialising the experiment

URL of experiment:

Description of the problem:I built my experiment on PsychoPy and uploaded it to Pavlovia, but when I click on the URL and try to run it, it gets stuck on initializing the experiment. I have opened the console tab and the message it shows is this:

I went to line 209 where there was a comma on an empty line so I brought it to the previous line (font: ‘Arial’) after which the comma was missing.
Despite this the problem persists and the consol reports the same error…

I’ve also noticed that there is this message when I place the cursor on the exclamation mark:
Schermata 2021-05-23 alle 21.33.44

My knowledge about coding is zero, so please help me out!!
Many thanks,


There’s a bug in PsychoPy which gives an error if you have a text element that starts empty. Add a space to instrText.

1 Like

thank you very much!! Actually now I have another problem which I’ve seen you discussed on another topic… ReferenceError: frameDur is not defined.
But still I don’t understand what I should do, because as I was saying I am very new to all this!

According to my crib sheet

ReferenceError: frameDur is not defined frameDur is a PsychoJS variable used for calculating frame durations. This error tends to occur when the JS has not compiled correctly, and so PsychoPy fails to declare the builtin variables in the JS code. The actual error is usually visible from the Psychopy dialog.

But the Psychopy dialog doesn’t show any error :frowning:

What is line 96 of the JS file?

1 Like

Sorry maybe it’s easy but I simply don’t understand how to proceed…thank you for your help!!

That line shouldn’t have an error which is why you probably need to look at PsychoPy itself when syncing.

You could also try setting the experiment to inactive and then active/piloting again.

Should I look at the script of the task in Psychopy?
Or maybe at the code component in the builder?
When I run the task from Psychopy it reports no errors…

What happens when you press the sync icon in Builder? Does it turn green? Do any messages appear in the runner or in a pop up?

When I press that icon it just appear a window where I have to describe the changes I’ve made…I left it blank and pressed ‘ok’. Nothing appeared nowhere; then I tried to run the experiment and it worked. This is the runner when I was about to start

I notice that you have two sets of JS files in your repository. Pavlovia can only cope with one experiment in each folder. I would recommend that you copy your psyexp file and resources to a new empty local folder and create a new project.

1 Like

I0ve done what you suggested and then pressed ‘sync’
This window opened up: