Some pictures randomly flashing too quickly on screen in a loop

I’ve looked around online but haven’t been able to find another thread with this problem. I currently have loops set up in Builder that sequentially display pictures that it pulls from a hyperlinked Excel file. Each picture is set to be displayed for 0.5s, during which a participant is to make a response (Go/No-Go task). Before each picture is an ISI/fixation point that lasts for 1.5s.

Sometimes, the loops run perfectly fine and each picture flashes on-screen for 0.5s. Other times, however, some pictures flash too quickly to be really seen/make a response. There doesn’t seem to be a pattern to which pictures flash too quickly (it’s not the same pictures flashing too quickly every time this happens). All pictures are in .JPEG format.

I can’t seem to find anything in the code that would cause this mistake. In Builder, the timing of everything is set up as I specified above. Additionally, like I said, sometimes it runs with no problems. Any thoughts as to what could be causing this? Thanks!

Is this when you run locally or online, or both? And can you link your experiment either way?

Both locally and online. Here’s the experiment:


You’ll need to make your repository public. From your experiment page, go to “view code”, then settings -> general -> permissions.


I haven’t looked at your files, but a common issue here is because it takes a finite time to load an image from disk. So if you want to display an image for a short time, you would ideally load it before you need it to start displaying. In your case, this would be during your fixation point/ISI. So insert a “static period” component that overlaps with that time period. Then, in your image component, instead of setting it to update “every repeat”, set it to load during your newly-created static period.

Thank you for the advice! This made a lot of sense so I’ve set it up so that it looks like this in Builder:

However, when I ran the experiment, I still had the issue of some pictures flashing too quickly on screen. By the looks of it, have I set it up properly?

That looks correct, and you should keep this arrangement for optimum performance.

But if you are still experiencing issues, then you need to look elsewhere. Have you quit all other software, other than PsychoPy? Have you disabled competing background processes, like DropBox and anti-virus scans? Have you disconnected from the internet, etc?

You should certainly also be looking through the log file and the warnings that pop up in the runner window.

I will close all background processes and give this a go! I intend to upload the experiment to Pavlovia for participants to access online - do you imagine this being a problem unless I specifically tell them to make sure they’ve closed all their background processes and open windows?