Setting up standalone 2023.2.3. no 'audio library' in preferences

Hi. Psychopy standalone 2023.2.3.
not audio library available ? see capture

there is a similar post here:

but no solution.

@jon should I download a different version? < I don’t want to spend ages just migration the task to a different system.

I also complains about not having the right pandas (it is a fresh install) have not run anything on this yet. Seems odd

I normally run 2021.2.3 but that gives grief with Trojan warnings and I got grilled by IT dept, when i wanted to copy what i had to this new system.
So trying to install the last version of psychopy.

Audio library is normally PTB, audio latency mode 3. use a M-Audio solo for sound.
the new install does not show any this in the menus but it does show psychtoolbox ( in the info :

PsychoPy 2023.2.3

Paths to files on the system:
userPrefsFile: C:\Users\MJR87\AppData\Roaming\psychopy3\userPrefs.cfg
appDataFile: C:\Users\MJR87\AppData\Roaming\psychopy3\appData.cfg
demos: C:\Program Files\PsychoPy\lib\site-packages\psychopy\demos
appFile: C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\

System Info:
Operating System: Windows-10-10.0.19045-SP0
Processor: Intel64 Family 6 Model 186 Stepping 2, GenuineIntel
CPU freq (MHz): 2800.0
CPU cores: 12 (physical), 16 (logical)
Installed memory: 16815702016 (Total), 8996646912 (Available)

Python info:
Executable path: C:\Program Files\PsychoPy\pythonw.exe
Version: 3.8.10 (tags/v3.8.10:3d8993a, May 3 2021, 11:48:03) [MSC v.1928 64 bit (AMD64)]
(Selected) Installed Packages:
numpy (1.24.4)
scipy (1.10.1)
matplotlib (3.4.3)
pyglet (1.4.11)
PyGLFW (2.4.0)
pyo 1.0.4
psychtoolbox (
wxPython (4.1.1)

OpenGL Info:
Vendor: Intel
Rendering engine: Intel(R) UHD Graphics
OpenGL version: 4.6.0 - Build
Shaders supported: True
(Selected) Extensions:
GL_ARB_multitexture: True
GL_EXT_framebuffer_object: True
GL_ARB_fragment_program: True
GL_ARB_shader_objects: True
GL_ARB_vertex_shader: True
GL_ARB_texture_non_power_of_two: True
GL_ARB_texture_float: True
max vertices in vertex array: 1048576

Ah, yes, this has moved from Preferences to the Experiment Settings because it turns out to be something that many people needed to change on a per-experiment basis rather than for the whole installation


I don’t use the builder as I have code that does what it needs to do and it’s a for a trial so it’s not going to be changed. Do I need to specify the audio library and latency in the code, or is ptb and latency 3 a default.