Sending triggers via serial

I am having some issues sending triggers via serial port

I am connected to a Lumo fNIR using their supplied USB serial port cable. I have the FTDI drivers installed for the cable to work. I have checked the device manager, and it registers the cable as COM3 and recognizes it as a serial device.

I have followed the instructions on the PsychoPy page for the serial port device (both using the component or just code) and it doesn’t send a trigger. I have the Lumo device set to record, and it apparently marks the triggers with a white line. I have been unable to make this line appear.

Some questions to help me:

Is there a way to test that a serial trigger is sending from one PC to another?

Which “parity” option should I be using?

Is there a serial trigger demo I can use to test?

Any help would be great.

Thank you

Hi There, are you using tghe new “serial” :serial: component?

Becca

I tried with the serial component and also with code and I’ve been unable to send a trigger

Hi @Jdigg,

The parity setting is an error checking procedure, in this case setting it to None or Off is fine. You can read more about it here (other articles are available - this is just one I found that seems to explain it well!).

As you’re receiving no errors, what is usually happening here is an address error. But it sounds like you have the correct address from what you’ve said here. I’ve not worked with a Lumo device before, but are there certain bytes it’s expecting to receive as a trigger? For example a string, character or an integer within a certain range? This information should be provided within the documentation for the device somewhere.

Also, how long are you setting the pulse for? By that I mean what is the stop duration in the Basic tab of your serial port component?

There is a demo here (attached), but this has the default address and start/stop values etc., you can just change these to match your address. It might be worth trying different USB slots if you have them available, and also checking that the baudrate value is correct (again this should be in the documentation for your device).

So sorry that I’m not being more specific here, every device and set-up is slightly different so it’s difficult to say what could be happening!

Thanks,

Kim
trigger_test.psyexp (13.4 KB)