Script Doesn't Run with EEG Serial Out (Deymed Truscan EEG)

OS Win10
PsychoPy version 3.8
Standard Standalone? (y/n) If not then what?:
What are you trying to achieve?:

I need to integrate an EEG trigger in my Builder script to measure the event related potentials for my stimuli.

What did you try to make it work?:

I have tried to identify the right port for the EEG system I use (Deymed Truscan EEG) which seems to be a USB-C serial port and added the corresponding address to the EEG serialport function in the builder.

What specifically went wrong when you tried that?:

When I run my script without the Serial Out component it runs perfectly fine, but as soon as I add the Serial Out component to my Trials the experiment won’t run anymore. The following output was generated when I fail to run the script:

Generating PsychoPy script…

Running: D:\My Documents\DesktopUser\TMS-EEG 12-07\

2848.7902 INFO Loaded monitor calibration from [‘2023_01_12 18:17’]
pygame 2.1.0 (SDL 2.0.16, Python 3.8.10)
Hello from the pygame community. Contribute - pygame wiki
WARNING: pytables package not found. ioHub functionality will be disabled.
Traceback (most recent call last):
Traceback (most recent call last):
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\iohub\”, line 56, in run
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\gevent\”, line 336, in start
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\gevent\”, line 253, in init_socket
self.socket = self.get_listener(self.address,
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\gevent\”, line 263, in get_listener
return _udp_socket(address, reuse_addr=cls.reuse_addr, family=family)
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\gevent\”, line 308, in _udp_socket
File “C:\Users\user\AppData\Local\Programs\PsychoPy\lib\site-packages\”, line 563, in bind
return self._sock.bind(address)
OSError: [WinError 10048] Only one usage of each socket address (protocol/network address/port) is normally permitted: (‘’, 9034)
6.3760 WARNING User requested fullscreen with size [1536 864], but screen is actually [1920, 1080]. Using actual size
2896.3840 WARNING Parameter baudrate has unrecognised inputType “int”
2896.3863 WARNING Parameter bytesize has unrecognised inputType “int”
2896.3887 WARNING Parameter stopbits has unrecognised inputType “int”