Scaling card task did not appear

Hi all,

I have an issue with screen scale task using credit card. I run an experiment with card scaling task and some participants reported to me that the card task did not appear (and it seemed to happen to some (not all, at least one of my colleagues and I have no such issue) of those using Chrome. I’ve tried it to all my devices, using Chrome, and yet failed to replicate the issue).

To fix this issue, I made an additional routine functioning as a cushion, which indicated some instruction for the scaling task and an message to press ‘p’ to proceed, thinking that it was skipped for being the first routine of the experiment. After inserting the cushion routine, however, another participant reported that when he pressed ‘p’, a message appeared to the screen to leave the experiment.

Anyone with similar issues?


Check you have event.clearEvents() in Begin Routine.

The screen scale routine can skip if the previous routine ends on a space. I’ve also just added a min 1 second before moving on, which should help.

Thank you for suggestion. I’ve updated my code and hope that work.