psychopy.org | Reference | Downloads | Github

Save Routine data in just one tab in excel

OS: Windows 8.1
PsychoPy version: 1.85.6

Hi,

I had to modify the structure of my experiment in which the participants answer moral dilemmas by pressing one of two letters. Before the modification, the data showed which letter the participant pressed and the RT in one tab of the excel file. Now I divided the task in 2 routines with a loop between them, in one routine the dilemma is presented and the participant presses space bar to continue to the question and the second routine in which the participant presses one of the two letters to answer the question. The problem is that now the data is dividing each response in different tabs on the excel file. So instead of showing one tab with all the letters and RT of all the responses, the output shows 20 different tabs for every question response.

Also, is it possible to include the RT of the spacebar response in the same tabs of the dilemmas responses?

Any sugestions suggestions?

Hi Bruno, your question is a bit hard to parse:

Loops surround routines, they can’t go between them. We probably need to see a screenshot of your flow panel to understand the arrangement you have.

Firstly, avoid the Excel output option. It splits data for each loop onto a separate tab, which is seldom useful. You would be better off with a .csv file, which puts all data into a single tabular arrangement.

Secondly, that there are 20 tabs seems very odd. We really do need to see that screenshot.

Hi @Michael

Sorry, my bad :stuck_out_tongue:

the “loop_perguntas” is the one giving the multiple tabs problem.

Here is the rest of the flow panel:

And the excel data output:


I’ll search more about .csv files, thanks for that.

@Michael

My .csv file looks like this:

Is this normal? It’s really hard to see the data with the output data file formatted like this.

No, it’s not normal. CSV stands for “comma separated values”. The commas should indicate to Excel to separate the values between them into separate cells. But sometimes this can trip up users in Europe, where the comma can be set to act as a decimal point. Check the settings in the import dialog where you get to choose what the value separator is.

The end results should be a normal looking spreadsheet, with values in neat columns, under their correct variable names in the top row.

OK, so this makes sense. That loop gets run multiple times, as it is itself nested within other loops. Therefore, it creates a new tab each time. This is certainly a reason to avoid Excel format in this case, and use .csv instead, in which case all the data should end up in the same table.

This may sound a little bit silly, but where exactly in the settings I can change the value separator? I’m trying to find the import dialog to change but I’m just not able to find it.

This issue is can be solved either within Excel or at the level of your operating system localisation settings, and depends on version and platform. So suggest you Google “excel import csv europe” and find the easiest solution for your particular combination. (i.e. you might not want to change your localisation settings for just this one issue, but if you do, it avoids needing to do things on each file import, which is a trade-off decision you need to make for yourself).

Hi @Michael
I looked for some solutions and what worked for me was to change the software that opens the CSV file. So I downloaded the LibreOffice which allows you tu choose what value separator you’d like to use when you open the file. Still, now I’m having some minor problems with the data output.

As you can see in the image, the dilemmas responses are repeating twice through the file (even if I responded just once in the experiment). Also, the full text and question of each dilemma is showing in the data. Is there a way to take them off the data after the experiment without having to exclude the columns in every file created? I already have other columns with the dilemma name, making unnecessary having the full dilemma in tha data.