Routines Do Not Show Up In Pavlovia


Here is the link to my Pavlovia upload: trailMaking [PsychoPy]

I downloaded this task from Pavlovia, and I want to add more routines before and after it. I think the code in this task will not let me display anything else. Does anyone know how I can display more routines so I can edit this task? I have added routines before and after what was downloaded from the task, but they do not display on Pavlovia at all. I appreciate the help in advance.


If you can see the new version on Gitlab then you have a very common cache issue.

Use Ctrl-Shift-R or an incognito tab or a different device or browser to run the latest version.


I have cleared my cache and the problem still persists.

Is there any other action I can take? It still does not work. Thank you in advance.

What did you do to clear your cache? Have you tried an incognito tab? Have you checked on Gitlab to see if the new files were uploaded?

I am assuming that there is no issue with adding the routines in Builder and pressing the sync button.

Hi. I cleared my cache on my browser and re-signed into Pavlovia, I have redownloaded the task and added routines before uploading to Pavlovia, and have tried in an incognito window. Yes, the new files are on Git. The problem still persists. I’m not sure if the code rewrites over everything or what the issue is. Thanks in advance.

What version of PsychoPy are you using. I notice your experiment has an html folder.

I have the newest version of PsychoPy and PsychoPy3. Which one is correct? Thanks.

More specifically, the newest version of PsychoPy is what I am using to upload this.

Aha. You may need to delete the online repository and local git files and folders and recreate it without html in Experiment Settings / Online