psychopy.org | Reference | Downloads | Github

Routine tabs disappeared from builder interface

OS (e.g. Win10): macOS Catalina
PsychoPy version (e.g. 1.84.x): 2020.2.4
Standard Standalone? (y/n) y
Hi all.

I was trying to edit a loop and I think I moved some tabs of the routines around and somehow the tabs all disappeared. I am now not able to edit the routines. I tried open the tabs from clicking and double-clicking the routines in the flow panel but nothing shows up. I don’t think the routines are all deleted because I can still see them in the scripts and I can’t seem to edit any new routines as well. Also, I can’t seem to find relevant setting options in Preferences. I am very new with psychopy so any help is appreciated. Thank you!

Does this persist when closing and reopening PsychoPy?

Hi

Yes it does. I tried quitting and reopening psychopy but it didn’t work.

That’s a strange one… Does this only happen for this experiment, or do you no longer have a Routine panel at all?

I think it is only with this experiment. I opened a demo experiment and the routine panel is present.

That narrows it down then! Could you share the .psyexp file for your experiment with me? There’s probably something missing from that which is causing the panel to not be drawn.

Sure. Here it is, thank you for your help!
EXP.psyexp (54.4 KB)

When I open this file it presents the panel just fine… However I’m on Windows, so I’ll get @jon to test it on his Mac! Could you also send over your prefs file? You can find it by going to View -> Themes -> Open Theme Folder then going one folder up, the file is called userPrefs.cfg. I’ll try it out with my prefs set to exactly the same as yours and see if it’s something in there! If it is, then deleting the prefs file should reset all prefs to default and fix it (though please send me the file first so I have record of what was breaking!)

Unfortunately when I clicked on ‘Open theme folder’ no new window opened up. I tried numerous times and nothing happened. I’m very sorry for all the hassle. Is there some other way to access the file or is there something else I can try? Thanks!

That experiment opens fine for me too. Could you open the Runner, then go back to Builder and open again? I want to know if any messages pop up in the output of Runner view when it opens


Here is what happens when I click on View->Open runner view.
And when I click on View->Open builder view from the runner window, it goes back to the original window I had

Also, I tried deleting and re-downloading psychopy and it didn’t work. I tried this on someone else’s laptop and it opened up fine. Please help.

Have you tried getting someone else to make a minor change and then save it (rather than just opening it) and then trying to open that edited file?

That’s a good shout @wakecarter, give this one a go - opened in my PsychoPy version and then Save As’d

EXP.psyexp (54.4 KB)

Thank you so much! That worked. I still have no idea why they disappeared in the first place but nonetheless I can continue working on it now.

Yes thank you! That one opened up fine!

Thanks for bringing this up, I’ll check the differences between your original and the re-saved version, hopefully we can track down what caused this and avoid it happening again!

1 Like