Python: OSError: can not load library file (.dll): error 0x7e

Hello everyone,
this question is related to python.
I am trying to load .dll files in python 2.7, but there is an error 0x7e. I am using Anaconda python 2.7: 64 bit, Psychopy2 1.83.04: 64 bit, Qmix SDK 64 bit (contains .dll files) on 64 bit windows 7. I did the same programming in other laptop with with same version of software with windows 10: 64 bit and it worked really fine. I have also install ‘Microsoft Visual C++ Compiler package for python’ as well as I have put .dll folder path in to Environment variable to highest priority. I am sending you the trace back. Please take a look and give me some advise.

Trace back (most recent call last):

File “”, line 6, in
qmix_bus = qmix.QmixBus(config_dir=config_dir, dll_dir=dll_dir)

File “”, line 90, in init
self._dll = self._ffi.dlopen(self.dll_file)

File “C:\ProgramData\Anaconda2\lib\site-packages\cffi\”, line 140, in dlopen
lib, function_cache = _make_ffi_library(self, name, flags)

File “C:\ProgramData\Anaconda2\lib\site-packages\cffi\”, line 786, in _make_ffi_library
backendlib = _load_backend_lib(backend, libname, flags)

File “C:\ProgramData\Anaconda2\lib\site-packages\cffi\”, line 782, in _load_backend_lib
return backend.load_library(path, flags)

OSError: cannot load library C:\Users\vtuser\QmixSDK\QmixSDK-64bit\labbCAN_Bus_API.dll: error 0x7e


Hello Ravi ¿is your problem solved currently? My name is Violeta, I´m from México City. I’m trying to install packages from Python, I have seen video tutorials in Youtube about how to install pip and Python adequately. But my problem persist: I can’t use library, it just doesn’t run. Please ¿could you help me? I’ll be so grateful with you. I send you a hug.

Hello Ravi

I realize that this is an old post, and I am sorry to bother you with this. I am setting up a Cetoni system with Qmix SDK, and I have the exact same error on the labbCAN_Bus_API.dll.

Did you figure out what the problem was or how this could be handled?


What version of Python are you using?

Thanks for your suggestion. I updated Python and Anaconda to the latest version and it worked like a charm!