psychopy.org | Reference | Downloads | Github

Can't run PsychoPy v2021.1.0 Onwards - 'DLL load failed'

I’m unable to run any .psyexp files at all without encountering this error message:

Welcome to PsychoPy3!
v2021.1.0
Generating PsychoPy script...

## Running: C:\Users\zelez\My Drive\tLab\Precision Phenomenology\Colour calibration\Isoluminance-Psychopy\test_lastrun.py ##
55.4408     INFO     Loaded monitor calibration from ['2021_09_15 12:12']
1.0988     WARNING     We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use ['sounddevice', 'PTB', 'pyo', 'pygame'] (in that order).
Traceback (most recent call last):
  File "C:\Users\zelez\My Drive\tLab\Precision Phenomenology\Colour calibration\Isoluminance-Psychopy\test_lastrun.py", line 18, in <module>
    from psychopy import sound, gui, visual, core, data, event, logging, clock, colors
  File "C:\Program Files\PsychoPy3\lib\site-packages\psychopy\gui\__init__.py", line 45, in <module>
    from .qtgui import *
  File "C:\Program Files\PsychoPy3\lib\site-packages\psychopy\gui\qtgui.py", line 35, in <module>
    from PyQt5 import QtWidgets
ImportError: DLL load failed: The specified procedure could not be found.
##### Experiment ended. #####

I’ve tried installing and running all the standalone versions, both 32 and 64 bit, from v2021.1.0 onwards. All of them produce the same error for me.

My machine is a ThinkPad Carbon X7 running Windows 10 Pro version 21H1.

This problem seems to have come up a few times, but the advice in previous threads hasn’t helped me:

  • Sep 2018: Packaging issue that was solved in a future version
  • Feb 2019a: problem was a university security system. I am running this on my private device
  • Feb 2019b: unsolved
  • Feb 2019c: packaging issue, solved in future standalone update.

Someone else has also posted this same bug issue on the PsychoPy Github. Help?

I got it to work through Anaconda, FYI, for anyone reading this in the future.