Pynetstation - unreachable host error

Hello, I’m trying to send triggers from PsychoPy (v2024.1.4) to EGI (Acquisition v5.4.2.) but I get the following error:

This is the code that I’m using which generates the error (copied from here: Sending triggers via EGI NetStation — PsychoPy v2024.1.4):


I have additionally tried to run the Stroop example with triggers (link: GitHub - nimh-cmn/stroopEGI: Demo PsychoPy experiment with EGI EEG amplifier events for Stroop Experiment) but I get the same error.

Additional information
I have disabled the wifi connection on the computer, the Ethernet properties are the following:

I have checked the netstation IP & amplifier IP adresses, and they are correct.

What am I doing wrong? Thanks in advance!

I have tested the same code on a different computer and it worked. The main difference is that this computer has windows 10 while the computer giving the error has windows 7. Would it be possible to use windows 7 for this?


My first guess is that Windows 7 needs more suggestions on networking settings (Windows 10 may be smarter). Try putting in the following to your network adapter settings:

X - Use the following IP Settings
IP Address:
Subnet Mask:
(if forced)
Default Gateway:

Once these are set, you can try to ping the amplifier using the windows CMD:
ping or just try your experiment again.

Thank you for the quick reply!

I’ve tried the following network settings:

IP address: / / /

Subnet mask:

But it did not work, the error I get however is slightly different now:

Is this helpful for diagnosing the problem?

Many thanks in advance!

The error message is merely saying that a network connection could not be made by timing out instead of unreachable. Could be a few causes.

You mentioned that it worked from a windows 10 computer but not windows 7. How are you swapping them in and out? Just looking to verify that the network physical connections are in the same hub and cables to rule out basics.

If you open a web browser on either windows computer can you access ?

I just take the ethernet cable that was plugged in the first computer, and plug it in the second computer, nothing else changes.

On the windows 7 computer (the one that doesn’t work) I cannot access
On the windows 10 computer I can, and the expected page shows up.

And just to verify that the webpage won’t load with the IP?

The package should work on windows 7, but this sounds like a windows issue. Perhaps there are multiple network adapters on the machine or you could try a USB-to-Ethernet adapter to troubleshoot.

Since we run our machines fairly lean, when issues come up we usually just reinstall or upgrade to the newest windows possible.

There were indeed multiple ethernet cables connected, which seemed to be the issue. Unplugging the other ethernet cables did the trick. Thank you very much for your help!