psychopy.org | Reference | Downloads | Github

Pynetstation (egi) with python 3


#1

Hello,

When trying to import egi.simple I get this error:

However I manage to successfully connect to the NetStation and send events with no problem with a version of Psychopy3 that uses python 2.7

Is there some sort of incompatibility between the egi module and python 3?
I would like to code in python 3. What could I do to solve this problem?

Thank you very much in advance!!!


#2

Please see this post by @jon:

Yes, it looks like that external dependency (which doesn’t seem to be actively maintained any more) has issues under Python 3. Until someone shows the egi library some love, it might be best to stick to Python 2.