psychopy.org | Reference | Downloads | Github

Py2exe and Psychopy manual install


#1

I am trying to bundle a Psychopy application using py2exe on Windows 10. Because for some reason py2exe’s installer will not let me point it to the Python interpreter inside the Psychopy installation at C:\Program Files (x86)\PsychoPy2\python.exe, and it insists on C:\Python27\python.exe instead, I figured that I could just use the Psychopy manual install method to install all the Psychopy stuff with the interpreter which the py2exe installer wants to use.

Pip installs all the dependencies but hangs on installing PsychoPy:

pip install psychopy
Collecting pyobjc-framework-Quartz (from psychopy)
Using cached pyobjc-framework-Quartz-4.1.tar.gz

In addition to it hanging, it seems strange to me that it would be trying to install a Quartz objective-c Python framework on Windows.

There are other things I can try here, like trying harder to get py2exe to point to the other Python interpreter, using the Anaconda installer instead of pip to install PsychoPy, trying PyInstaller instead of py2exe, looking at the PsychoPy package to figure out where things are going south. However, that “pip install psychopy” was not working for me seemed worth mentioning here now.

-Allen

P.S. I have used “pip install psychopy” within the last year to install PsychoPy on Ubuntu and it worked perfectly.


#2

We encountered the same issue, trying to run pip install psychopy on a Windows 10 Python 2.7 Anaconda environment.

Installing a previous release, ‘pip install psychopy==1.85.3’, went flawlessly.


#3

That’s an interesting one. I have been working on the setup.py a lot lately, so that the dependencies get included too, so maybe something has gone wrong there or maybe it’s because I’ve built them on a mac and accidentally included something I shouldn’t have done.


#4

This worked, thank you.

- Allen


#5

I have this issue also (Win7-64 bit, Win10-64 bit). I haven’t tried the

pip install psychopy==1.85.3

yet, I’m working on getting an anaconda environment exported so I can install this on a machine not on the internet.

I unpacked the psychopy wheel, and noticed in the METADATA file:

Metadata-Version: 2.0
Name: PsychoPy
Version: 1.85.6
Summary: Psychophysics toolkit for Python
Home-page: http://www.psychopy.org
Author: Jonathan Peirce
Author-email: psychopy-dev@googlegroups.com
License: GNU GPLv3 (or more recent equivalent)
Download-URL: https://github.com/psychopy/psychopy/releases/
Description-Content-Type: UNKNOWN
Platform: UNKNOWN
Classifier: Development Status :: 4 - Beta
Classifier: Operating System :: MacOS :: MacOS X
Classifier: Operating System :: Microsoft :: Windows
Classifier: Operating System :: POSIX
Classifier: Programming Language :: Python

Requires-Dist: pyobjc-core
Requires-Dist: pyobjc-framework-Quartz


#6

Just had exact same problem - going back to 1,85.3 has fixed it for now