psychopy.org | Reference | Downloads | Github

PsychoPy3 - won't run on macOS10.11 (El capitan)

Hi Everyone,

I’m trying to install the new version of PsychopY on my Mac (version IOS 10.11 - El Capitan).
When I’m trying to open it, nothing happen (the window “verifying packages” stay on the screen)…

I already tried to delete last version of Psychopy to see if there were a incompatibility between the two versions but it doesn’t work.

So I tried to install packages to run psychopy experiment on python consol but the terminal never finish to install “hdf5” (after installing HomeBrew).

Any Idea ?

Thanks

Hi,

No solution but I could just possibly confirm your MacOS-problem with packages in psychopy3, where I currently have problem with installing psychopy3 through Anaconda on MacOS Mojave.

Everything seems to be fine when installing the dependencies through the Terminal, but I cant get Anaconda/Spyder to access/identify psychopy.

Best
Simon

Hi Simon !

I didn’t really find the problem but I tried an alternative way that worked.
I had PsychoPY3 on my MacBook Pro so I used an USB to copy/paste it on my iMac El Capitan and it worked.

I can now open it and use it without any problem.

Best,
Charlotte