psychopy.org | Reference | Downloads | Github

Psychopy freezes - troubleshooting advice?


#1

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): OSX El Capitan 10.11.6 & OSX Sierra 10.12.6
PsychoPy version (e.g. 1.84.x): 1.84 & 1.85.6 & 1.85.4
Standard Standalone? (y/n) If not then what?: yes
What are you trying to achieve?: Looking for advice to debug an fMRI task - task freezes under certain conditions (on OSX El Capitan, 4 GB memory, psychopy v 1.85.6) and can’t figure out why. It will freeze (unresponsive to button presses, esc key, will not advance to next routine) at seemingly random points in the trial loop (sometimes 20 trials in, sometimes 100, etc.). Have to force-quit out of the task each time. When I do that, there is no error message, no csv of data, and a written, but completely empty log file. Since there doesn’t seem to be many clues upon force-quitting, I’m having trouble determining what might be causing this problem.

What did you try to make it work?: I’ve tried the task on a 2nd computer (OSX Sierra; 16GB memory; psychopy v 1.85.4) and I can’t recreate the freezing here, leading me to believe that maybe it’s a memory problem. That said, I can’t figure out what’s going wrong that it is requiring a TON of memory, if that’s the case. I also don’t know why I wouldn’t get a memory error message. I’ve also tried running in different versions (1.84), and the problem still occurs.

What specifically went wrong when you tried that?: No error message except the error messages I get all the time, even when the task works:

1.5902 |ERROR |Requested audio device ‘auto’ that is not available on this hardware. The ‘audioDevice’ preference should be one of [u’Built-in Output’]

13.8349 |WARNING |psychopy.parallel has been imported on a Mac (which doesn’t have a parallel port?)

Any advice for how to best troubleshoot this given no logging and/or known issues would be much appreciated. Thanks!


#2

I just want to add an update to this…

When I compile the script and run the task from the coder window, it works. However, it still freezes when I run the same task (same version/same computer) from the builder. Does anyone know what could possibly be causing this behavior?

Thanks for your help!