psychopy.org | Reference | Downloads | Github

Could not find a Cedrus device

Hi,

I have installed PsychoPy 1.84.2 and trying to run a small testcase experiment using Cedrus box.

I have downloaded the FTDI drivers and can see the box as “USB Serial port” in the device manager (COM3)
I downloaded pyxid and put it in Lib/site-packages/

but when I run the experiment I immediately get
3.2445 ERROR could not find a Cedrus device

Is there any place where I can define in PsychoPy where my Cedrus box is connected (COM3 etc ) ?

I tried in Win to move it to COM4 but the same error occur.

If anybody have suggestions I’d be very happy :slight_smile:

Thanks!
Noa

anybody has an idea ?

Hi Noa,

I have recently got a cedrus box working and had to get through a similar set of problems. I also have it in COM3.

If you haven’t already have a look at the github page for the cedrus box: https://github.com/cedrus-opensource/pyxid

Try running this script in psychopy and see if it works.

import pyxid

devices = pyxid.get_xid_devices()

mybox = devices[0]

if myBox.is_response_device():
    myBox.reset_base_timer()
    myBox.reset_rt_timer()
    while True:
        myBox.poll_for_response()
        if myBox.response_queue_size()>0:
            response = myBox.get_next_response()
            print response

This is what I use to see if the box is working correctly before putting it into an experiment. Let me know what happens.

I downloaded pyxid from Cedrus. But when I ran your code - it seems that PsychoPy uses a different package which I cannot locate. When I run “import pyxid” I see that it uses this package:

<module ‘pyxid’ from ‘C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyxid-1.1-py2.7.egg\pyxid_init_.py’>

I do not have any directory names ‘pyxid-1.1-py2.7.egg’ in this location!

I do have “pyxid” which is the package I downloaded from Cedrus.

How can I tell PsychoPy exactly which package to import and how come I have files I cannot see ?

Thanks!!

Did you use one of the packaged versions of psychopy? There was a problem with the bundled version of serialio.py (or possibly serial.py) that stopped me being able to connect to a Cedrus LSC-400. I tried downloading a newer version, but ended up building 1.84.2 myself, which pulled down an updated serial.py and this fixed it for me. I’ve not tried the bundled 1.85.x install to see if the fix is in there, but I imagine this should be fixed by now.

Best, Jon