Problems with hearing auditory stimuli

Hi everyone!
I’m working on a project for the digitalization of some linguistic tasks. Currently I’m using the PsychoPy version 2022.2.5 on a Windows10 system.
I’m having some problems with the auditory stimuli for my syntactic comprehension task (I’m running the experiment locally, not online). Participants hear auditory stimuli, i.e. a recorded sentence, and then they have to choose which one of the four images displayed on the screen best describes the sentence they heard.

I can see that the trial works and that the loop updates each time the images, but it’s not possible to hear any sound.
Both the visual and the auditory stimuli are listed in an excel file (condition file), their updating is set to every repeat and their order is set to sequential.
All of the sound files are in .wav format and in the general setting of PsychoPy I selected ptb as audio library. The volume is set to 10, so it should be audible.
No errors or warnings appear in the PsychoPy Runner.

Does anybody know how to solve this situation?
Any advice would be appreciated. Thank you in advance!

Hi, have you tried setting the volume to 1? If you see here, the maximum volume for a sound component is 1

Yes, I did, but nothing changes. 1 is the default setting, but I couldn’t hear, that’s why I tried with other values :frowning:

Would you mind sending me your task so I could take a look at it on my end?

At the moment I don’t have any link of the experiment that can be shared…
What do you need me to send, in order to give it a try? Is there a way to share it on GitLab privately?


Hi everyone,
unfortunately, I need to highlight this issue again.
The auditory stimuli in my experiment can’t be heard and I tried both on my computrer and on the computer of a colleague of mine.

When I run the experiment locally, I get this message from the runner:
ioHub Server Process Completed With Code: 0
################# Experiment ended with exit code 0 [pid:2240] #################

Does anybody know how to deal with it?
I really need to complete this project for my internship and this problem has been blocking me for weeks :frowning:

@mariapalmieri1 Sorry I missed this post. Yes if you add me on your project as a member, I can take a look at your files. My username is SueLynnNotts

thanks for your answer.

Unexpectedly, I solved the problem and it was way simpler than I thought.
The problem concerned merely the expected duration setting in the “audio properties” window. It was in seconds, while I was using milliseconds…

This was for sure an effective message for me, to pay attention also to the smallest things!

Thanks again for your help, I really appreciated it.

1 Like