psychopy.org | Reference | Downloads | Github

Problems pushing updates/commits to pavlovia

OS: Mac OSX high sierra
PsychoPy version: Psychopy3 3.0.0b4
Standard Standalone?: yes
What are you trying to achieve?:
I am trying to create a test experiment in builder, push it to pavlovia and run it online.

What did you try to make it work?:
I created a basic experiment in builder that simply presents text on the screen and finished upon pressing any button.

What specifically went wrong when you tried that?:
I am able to create the HTML folder, but psychopy3 seems to hang whenever I try to push my files to pavlovia. Specifically, I get the pop-up window that says

Synchronising...
Pulling changes from remote...done
Already up to date.
Pushing changes to remote...

and it never finishes (and no commits show up in gitlab on pavlovia. GIT is installed and updated. I use it on a daily basis without issue. Any ideas as to how I can get psychopy to push changes to pavlovia?

1 Like

I hear you. I just had the problem once myself, but then it worked. Not sure what’s going on but will explore it tomorrow. thanks

1 Like

Not a problem. Thanks for the reply. I am very enthusiastic about Psychopy3 and available to help with testing in any way I can.

Hi there, I am having the same issue… I completed my experiment a basic one, but when I sync with pavlovia it keeps loading… in the text box says “pushing to Pavlovia for the first time…” Any suggestions on what is happening or what am i doing wrong?