psychopy.org | Reference | Downloads | Github

Playing sounds (wav files) on a mac (1.90.2 / 1.90.3 differences)

I have a graduate student who has been making an experiment with Builder. The experiment runs fine on her PC. However, when I run it on my Mac (macbook air, macos 10.13.5) the sounds play but it sounds like the speaker is on helium i.e. high pitched. I’m using the latest version of psychopy.

Here is a link to a zip file with a simplified version of the experiment.
http://www.psy.dmu.ac.uk/macsound.zip

When you run it there should be ten words spoken, one after the other. This works fine on a PC. Does anyone else get the strange behaviour on a mac? Any idea what is causing this and what might be the fix?

Many thanks.

I wonder if anyone has looked at this?

Some more information…
The program works fine on psychopy 1.90.2 on a PC but on a mac the words come out in a high pitched voice.

On psychopy 1.90.3 the sound doesn’t work properly on either a PC or mac! On both platforms instead of playing the wav file there is a continuous tone played instead of the word.

Any suggestions?

This is usually something to do with the sampling rate not being at the expected frequency. It might be worth opening it in Audacity and checking what it is and potentially saving it a a different sampling rate (check elsewhere for recommended frequencies).

Have you tried changing the order of the sound backends in the preferences?

Michael,
Thanks for the suggestion. One problem solved! On the PC in preferences I had the audio library set as [u’pyo’, u’pygame’, ] whereas on the mac is was reversed. Changing the setting to: [ u’pygame’, u’pyo’, ] causes the high pitched playback on both PC and mac. Reversing the order causes the wav files to play normally.

However, I think I’ve found another issue and this is related to differences between versions 1.90.2 and 1.90.3. The experiment works fine under 1.90.2. However, with 1.90.3 instead of the wav file playing I hear a continuous tone in place. This happens on both PC and mac with 1.90.3. Reverting back to 1.90.2 causes the experiment to run OK again.

What changed between 1.90.2 and 1.90.3 that might cause this?

Sorry, I don’t know enough about sound to answer that.

Thanks @mark, this has been fixed in a very recent pull request on Github. When setSound was being called at the beginning of the routine, the default sound was used rather than one defined by the user.

1 Like

Thanks David! So will there be a new version, say 1.90.4, that fixes this?

Yes it should be in Psychopy 3.0.0b3

So, just to clarify, version 1.90.x won’t be developed any more and all efforts are towards version 3?

Thats right, we have moved to Version 3 where you can take advantage of the new PsychoJS library for writing online experiments and running them from https://pavlovia.org/. However, this will not affect how you run your existing experiments as the new releases are designed with this in mind.