Pilot study unable to run?

URL of experiment:

Description of the problem:

Hello, I’m currently trying to switch my experiment from inactive to pilot and every time I do it says “status changing, may take a few minutes” but then nothing happens. Am I doing something wrong? This is my first time using psychopy and Pavlovia

Hi Nadja

I have synched projects to Pavlovia before and changed their status (e.g. from inactive to piloting) but I am having the same issue so I think it might be an actual error (i’m pretty confident that I have followed the correct steps).

If anyone can help / let us know if there is an ongoing issue that would be great!

Edited to add: When I click to change the project from inactive to piloting a message comes up saying “the status is being changed, this may take a few minutes” and then nothing happens so I’m wondering if it is an internet/server issue?

What version of PsychoPy are you using?

Is there an index.html file in your Gitlab repository (click on View code to check)?

Are there any error messages when you sync?

I am using PsychoPy 2021.2.3 and synced a builder-made experiment to Pavlovia as a new project today. The icon on Psychopy turned green and the runner said that the sync was successful.

I can now see the new project but when I click on ‘view code’ to see the github page it says it is empty, so no index.html file. Just tried syncing again and Psychopy is telling me that the experiment does not correspond to an existing project and prompts me to make a new one.

I can try making a new project and get back to you with an update on how it goes?

Thanks for the help!

Also - on the Pavlovia project page the software platform is listed as unknown and the version is set to 0.

Ok so I tried the process again and synced the experiment to a new project when prompted. Then got the message in the runner saying it was successful:
Pushing files to Pavlovia
Pushing to Pavlovia for the first time…
Branch ‘master’ set up to track remote branch ‘master’ from ‘[[OAUTH key hidden]]’.

Checked this new project and it seems to have worked this time. Switched to piloting and loaded the beginning of my experiment.

EDIT: I am now having an issue with an ‘unknown resource’ error at the start of the experiment for a PNG file which is shown in the html/resources folder on Github so not as successful as I initially thought! I have tried running the experiment in an incognitio window and switching from pilot to running and back but no joy so far…

For unknown resource errors please see this page (and my many posts on the topic)


Yes - I have dealt with the unknown resource errors before. I rebuilt from scratch to make sure that there was nothing carrying over from previous iterations of my experiment causing the error (after following the advice in the linked resources).

Edited to remove the error message I got when trying to sync a from-scratch version of the experiment. I deleted everything and started again and syncing is working again.

Will revisit your advice RE unknown resource errors to fix the new error which has cropped up but hopefully syncing will keep working without needing to start over.

Thanks for your help

So I figured out where I went wrong with trying to pilot my study, my next issue is that when I attempt to try my study (in pilot mode) it takes me to another page that says ‘initializing’ and doesn’t take me to the experiment, it just says initializing over and over again. Have i missed a crucial step?

Is there an error message in the developer tools/console?