Pavlovia Survey routine not appearing in experiment once ran online

I have an experiment that runs properly online. I created a Pavlovia Survey to act as a consent form that the user will fill out before proceeding with the experiment. The survey is functional and is currently in the running status.

I tried adding the survey into the experiment using the Pavlovia Survey component in the builder, first through linking the survey ID, and then through a downloaded survey model file. Neither of them showed up in the experiment. The experiment would run as intended, except the survey would not show up, it would be skipped. I did make sure to clear my browser’s (chrome) cache data after syncing to make sure the .js files were updated. I also tried placing the survey in a different part of the routine timeline to no avail. The survey is referenced in the repository in the .psyexp file and the commit message is showing up on the .js file so it is in there, just not showing up.

Does anybody know what is going on, why it’s not showing up, or even where to start with fixing the problem?

Thank you in advance.

Have you added the survey routine to the flow?

Yes, I have.

Are you using the latest version of PsychoPy?

I’m using v2023.2.3

I fixed the problem. I am only a contributor to this project, and I realized that while my PsychoPy software has been updated to the newest version, the experiments version had been changed in experiment settings to a version that does not support surveys.

1 Like