psychopy.org | Reference | Downloads | Github

Pavlovia suddenly stopped working (since yesterday)


#1

URL of experiment: https://pavlovia.org/run/ipuz/testowy/html/

Description of the problem: Is there any general problem with Pavlovia now? Everything was ok since midnight today, when all my experiments stopped working - I can see blank white page only on my home computers.

I tried to update files via Psychopy (v3.05; it looks like files updated ok) and manually (updated ok), without any effect.

I also created a very simple experiment (see URL) - still the same.

Best regards,
Thomas


#2

Ah, shoot, I know what that is, but not technically a Pavlovia problem. When we released PsychoPy3.0.5 I forgot to update the online files to reflect the new version number, so your experiment is looking for 3.0.5 and not finding it. We’ll have it fixed shortly but ,in the meantime, you should be able to go to your experiment settings and set it to use a specific version (3.0.4). Then it should export the JS for that specific set of libs and run accordingly

sorry about that


#3

Thank you! It works with 3.04.

But now i see I have an another issue. Is it possible to state loop in the loop online?
Offline it works great - outer loop Conditions are XYZ.xlsx (with Parametr condsFile, and 3 conditions (A.xlsx, B.xlsx, C.xlsx)).
Inner loop Conditions are $condsFile.

When it runs online, I get an error: ReferenceError: item is not defined
(item is parametr in A-C .xlsx files).

EDIT: I fixed it. I do not why, but one variable (my counter for one trial, writen in Coder) was not “translate” into JS. After changing it into JS, all start to work correctly.

Best regards,
Thomas