Pavlovia stuck on initializing in piloting mode

URL of experiment:

Description of the problem: While in the pilot mode on pavlovia, the experiment will not run and is stuck on the initialising screen. I have tried to dig into similar question threads, but am not able to understand or implement the necessary changes. I need some more direct help if possible.

Look in the browser console . There is a message saying it can’t find your JS file. If I peek a bit, the question mark shouldn’t be there, but even after removing it, I don’t get a JS file. I would guess something is going wrong with generating the JS file.

hi @thomas_pronk,

I have a similar question when I try to push my experiment online. When I run the experiment on pilot mode, I get the error: Uncaught SyntaxError: Unexpected token ‘,’ (from the webbrowser controle - so this means that something is wrong in the JS generated script). Last time I got a similar message and I could fix it in my code because I added some code components myself.

However, this time, I haven’t added complicated code and I can’t see where in my code components there’s an unexpected comma that shouldn’t be there. I do have to add that I am using the new Textbox component, and I suspect that the translation for the Textbox into JS might still be buggy? I don’t know…

Offline, the experiment works ok.

Would you be willing to help me out with this?
Here’s the offline experiment: Longitudinal_SP.psyexp (59.2 KB)

Here’s the link to gitlab (I made it public): Rianne / Spaanstest · GitLab

I notice a JS error at the textbox named text. I think this is a builder bug, so I forked your experiment in order to pass it on to our builder devs. In the meanwhile I’ve got a possible workaround for you: try putting a bit of text in the textbox, say a space (" ").

I confirmed the bug and the workaround. Here is the ticket I made on the PsychoPy repo.

Hi @thomas_pronk, thank you for your prompt response.

So, would you suggest I should just try to code the experiment the old-fashion way, without using the Textbox component (i.e., so adding a code snippets?)? Just asking because I don’t know how long it’ll take for the bug to get fixed in the PsychoPy repo?

@ps2, maybe this post here would apply to you too?

O sorry, I assumed it concerned a text stimulus. My guess is the same workaround work for a textbox. Wanna try it out?

Hi @thomas_pronk,

I tried it out and the experiment starts up. However, the textbox does not register any keypresses at all (offline it does register keypresses). It’s really difficult to know what is happening because the issue concerns a component and not some code that I added myself manually…

I just created a new topic in the platform (out of desperation) in case anyone would have the same issue.

I don’t know if you have encountered such issues before?

So we’re got two thread about the same topics now? I’ll consider this thread closed and look at your other thread

1 Like

Ok, yes I wasn’t exactly sure who your helpful comments were directed toward. Thanks.

1 Like

Yeah sorry, things got a bit confusing here :slight_smile: