Participants cannot select 0 values in slider

Win11
PsychoPy 2022.2.4
Standard Standalone? (y)
**What are you trying to achieve?:
I have a working experiment that runs smoothly with a 0-100 slider:

While performing a pilot, participants complained that they could not select 0 values on the slider presented. They had to select another point in the scale and then click back on the 0 value so that the program allows them to select such an answer.

I have no idea what is happening or what to do to make it work correctly. I am afraid participants will refrain from choosing “0” answers just because psychopy does not seem to assume such an answer when given as first choice.

Does anyone have a clue about what could be happening?

Many thanks!
Mariana

Hi @Mariana_FPCEUP,

I’ve just set up a slider with the same settings as you’ve got here and I can select 0 straight away (see example). Could you please confirm which slider style you’re using, i.e. ‘rating’, ‘radio’ etc?

Thanks,

Kim
slider_0.psyexp (8.9 KB)

Hi @Kimberley_Dundas !

Thank you for your replay and example!
Indeed, your script does seem to work where my does not. I’ve created a copy including only the slider, which I am sending now. I now notice these warnings on the stdout:
WARNING: Requested display index does not exist. Using display index 0.
5.0420 WARNING Requested an unavailable screen number - using first available.

test.psyexp (20.7 KB)
valencetype_list.xlsx (8.0 KB)

Hi Mariana, :slightly_smiling_face:

I don’t know what the cause of your problem is but I tried something on your experiment and it seems to work fine, so try it yourself:

Imbar.

Hi @Imbar_Mizrahi!

Thank you. Unfortunately, it does not seem to work for me.
I wonder if it is something to do with my settings…
[I now know that the warnings I previously shared were not related to this issue (sorry for the noise there).]
@Becca , do you have any idea what could be happening?

Thanking you in advance

Hi Mariana,

Sorry but I am struggling to replicate this I am running PsychoPy 2022.2.4 on a Windows 10 (the OS version is the only possible difference as I understand it). When I download your test.psyexp and spreadsheet I can select 0 no problem. Have you tried this on any other device where it does work?

Becca

Hi Becca,

Thank you for your reply.
I have tried it on another device with Win10 and I have the same problem: I cannot proceed to the following question (by clicking on the tab) if I try to select a zero value (please see the video attached). Do you confirm that you can select 0 as the first choice, click tab and go to the next question on your device without any issues?

Many thanks

I’m on my phone so can’t download your code. What do you use to detect a response and end the routine? I’m wondering whether you’ve put >0 somewhere.

Hi Wakecarter, thank you,

That is one of my previous thoughts too… But I don’t think I did as you can see below:


This is really puzzling because if I change the minimum to -10, it accepts -10 and 0s just fine… The problem is only if the minimum 0 is set to 0.

Try baseline_slider_valence.markerPos as your condition. The issue is that a rating of 0 is False for your condition.

Unfortunately, baseline_slider_valence.markerPos as the condition does not solve the problem. However, if I remove the condition of selecting a value on the slider,

it becomes possible to select 0s. So it solves one problem but creates a new one: participants are now allowed to move to the next question without giving a response.