psychopy.org | Reference | Downloads | Github

Parallel port error with v1.85.0

OS Win 7
Version 1.85.4
Standalone Yes

I updated to 1.85.4 from 1.83.01 today and now get an error related to the parallel port that used to work in the earlier version. Error Message below. The previous version has been working fine for 2 years. Existing scripts and a new script do not work now. I hope that someone can provide some insight or an ability to revert to the earlier version of PsychoPy. No changes other than the new install of PsychoPy were made and the Port Test Utility is sending events to our Brain Vision software, so the card is working. Also have tried address as 3FD8 and H3FD8 (from Port Test) and get the same error.

Welcome to PsychoPy2!
v1.85.0
()

Running: C:\Users\DePauw\Documents\My Experiments\NEUR341_F17\Stroop\Stroop_1.py

pyo version 0.8.0 (uses single precision)
Traceback (most recent call last):
File “C:\Users\DePauw\Documents\My Experiments\NEUR341_F17\Stroop\Stroop_1.py”, line 111, in
p_port = parallel.ParallelPort(address=u’3FD8’)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\parallel_inpout32.py”, line 36, in init
_inp = self.port.Inp32(self.base + 0x402)
TypeError: coercing to Unicode: need string or buffer, int found