| Reference | Downloads | Github

Parallel output port error

OS (e.g. Win10):
PsychoPy version (e.g. 3.1.x):
**Standard Standalone? (y)
What are you trying to achieve?:

I generally build experiments using the Builder view, but I will be attaching the code, because I think it will be easier to troubleshoot. I am trying to output a signal from a parallel output port. This is the output cable that we are using.

I would like PsychoPy to output a signal which will communicate with our data collection device (PowerLab) to indicate the start and end of each trial.

This is the error that we receive:

File “Z:\Procedures\Visual Stimulus -Checkerboard\Visual Stimulus C25_O40 -”, line 83, in
4.4849 WARNING psychopy.parallel has been imported but no parallel port driver found. Install either inpout32, inpoutx64 or dlportio
6.4716 WARNING User requested fullscreen with size [1024 768], but screen is actually [1366, 768]. Using actual size
p_port = parallel.ParallelPort(address=‘0x0A’)
TypeError: ‘NoneType’ object is not callable

This is a sample of the code:

Initialize components for Routine “Baseline”

BaselineClock = core.Clock()
text = visual.TextStim(win=win, name=‘text’,
pos=(0, 0), height=0.5, wrapWidth=None, ori=0,
color=‘white’, colorSpace=‘rgb’, opacity=1,
p_port = parallel.ParallelPort(address=‘0x0A’)

What did you try to make it work?:

I have tried to download the drivers suggested by the error message, but I am having difficulty finding the drivers online.

Any help would be appreciated.

Hi, I am having the same problem with the drivers!
I am working on a 64bit Windows 10 using a 64 bit PsychoPy.
The inpoutx64 was not installed together with the rest of the packages and drivers.
The psychopy installation instructions provide information on the access for the packages that are needed.

However, the webiste linked to the inpoutx64 does not work any more.

Hi Marta,

Thanks for the response.

Did you happen to solve the problem? I figured out how to install the drivers. I ended up using inpoutx32.

Unfortunately, I don’t think that the driver is our issue. We found that the UBS-PPO cable that we are using is not appropriate.

Noo, I am still struggling with this.

I didn’t think that the cable would be the issue. I used the same set up to send triggers from Eprime and it worked well. How did you find out that it was the cable that caused the issue?

Also, how did you find the inpoutx32? The website listed in the instructions above also doesn’t work for this driver.


I posted in another forum and someone told me that we needed a USB-TTL emulator and that the printer cable we were using would not work. We are in the process of ordering an emulator.

I downloaded inpout32 from this website:

You have to place the downloads in your experiments folder (See picture).


Thanks so much for the link to the website!
I was worried that my computer would ask for admin rights and I would have to call the IT - but the driver download only includes a zip file. I copied the files like you did and it is all working well now.

Good luck with the emulator and hopefully your problem will also be sorted soon :crossed_fingers:

1 Like

Dear all,
I also encountered this problem when coding with Psychopy v3.1.2, on window 10 (64 bit)

However, when I switched to an older version (v.1.90.3), it worked,

Then, I checked the Changelog and found that from v3.1.1, there was one note on parallel:

But I am still confused because I already updated my inpout32.dll to the latest version v from the website mentioned by @Tmark, yet the noneType error is still there when using Psychopy v3.1.2.


I am not too familiar with the parallel output port function. You may receive more help if you create a separate post.

Have you tried moving the inpout32.dll file into the same folder as your experiment?

Thanks for your reply.
The inpout32.dll is in the same folder as my experimental script.

maybe create a separate post is a better option.