Online Study with Pavlovia: TypeError: this is undefined

Hi all!
I tried to set up my first online study using Psychopy and Pavlovia :slight_smile: The experiment consists of very simply task. After the instructions participants see two words and have to make a choice by clicking on one of the words. The instructions routine is closed by pressing the space bar. On my machine everything runs fine, but when I run the study as a pilot on Pavlovia it says (when I try to close the instructions by hitting space): “TypeError: this is undefined” which is pretty much non-informative :smiley:


Did I include something which is not supported by online studies? Here is what the browser conosole tells me if that helps:


Thanks for reading this :wink:

Hi Fabs, welcome back!

  • Note the toNumerical in the browser console. Line 661 in util-2020.2.js is executed when something goes wrong with converting some value to a number. It’s supposed to catch an error an show an error message to you, but this itself is going wrong. I think this bug in PsychoJS is known and a fix is in the scaffolds.
  • Next I see setPos, that suggests an issue with setting the position of a stimulus.
  • Finally I see test.js, line 377. Take a look over there to see what could have gone wrong.

Best, Thoams

Hi Thomas,
Thanks for you reply!

Now, the following strange thing happened: I had a look at the experiment one day after your reply and I got the same error. In the meanwhile the semester started and I was busy. Today, I gave it another try and it simply worked without a problem.

I created another version of the experiment and I receive the same error. After syncronizing the experiment several times, it worked.

Thus, everything is fine now, but I don’t know why :smiley:

But, thanks again!

1 Like

Happy you’re back on track!

1 Like