| Reference | Downloads | Github

Online study compiling to HTML, library files missing?

Windows 10
Psychopy V3.0.0b4

Hi All,

I’m trying to upload an experiment to my webserver, the necessary files don’t seem to be turning up in the /html/ folder.

The .php and .js folders I’d normally see, in older versions of psychopy html output, don’t seem to be there. Even if I manually copy across the folders I still get an error when running the study online. GET 404 (Not Found)”

Part of the problem seems to be that the new version is expecting a “lib” folder, while the older version used “js”. But neither folder is being created in the saved “/html/” folder.

Any suggestions?


Hi @George_Lovell, Psychopy 3 is currently releasing regular updates to software, so you will need to download the most recent release V3.0.0b9.

If you have any more problems after you have updated the software, please let me know.

Thanks, I’ll give it a go when I have time, in the meantime I compiled with 1.9.2 and this seems to be working:

It’s for a practical on monday so I didn’t have time for an extensive debug.

Thanks again.

OK, so with V3.0b9 (Py2) I get the same problem:

The html folder only contains:

  1. the resources folder
  2. the index.html file
  3. 2x .js files.

When I compile with 1.92 and 1.93 I get:

  1. Same as above
  2. the “js” folder
  3. the “php” folder
  4. “server” file

Does this mean I’m missing something?

No everything seems fine there, the functionality of PsychoJS has been updated such that you no longer need the php folder or server files, it is all handled server-side. All you will need is the JS and HTML files, along with your experiment resources in order to run an experiment on Pavlovia.

OK, but I’m putting the files on my own server to run the experiments, now that the php and server files aren’t bundled, does that mean that anything newer than PsychoPy 3 only works with Pavlovia and will no longer work with my server?

Best wishes,


Yes, for now the server scripts are not available as they are still developing, but see the note from Jon below.

OK, at least I know that’s a dead-end for the moment. Currently GitLab/Pavlovia/PsychoPy are not cooperating and I’ve not managed to upload a single file to Pavlovia.

Ok, are there any error msgs that can help to determine the problem?

On PsychoPy it just hangs as if it’s still uploading, however nothing arrives.
If I go to the pavlovia area and follow the manual gitlab instructions for the command line it tells me I have a security/access issue - something to do with passwords. Yet I’m using the password that was set up on the pavlovia account. Currently though I’m building a website/server to administer experiments for my undergraduate practicals - so the fact that I can no longer create studies with V3 and V1.90.3 seems not to work for me (missing "}"s in the code is a bit of a major problem.

Above you say you are using Python 2. Is that the case, and have you tried PsychoPy 3 running with Python 3? Here is the link to the download StandalonePsychoPy3-3.0.0b9-win32.exe

sorry that was a typo (v1.90.3). Currently on the Python 2 version, I’ll try 3 in a moment.

(re)installed Stand Alone, Py3-3.0.0b9-win32. When I ask it to synchronise a project it says “synchronising” but there is no additional feedback. Just a box saying that. Is there any indication of how long it should take? I’m on fibre broadband. The HTML folder on my PC is 50mb.

[](http://I see this on my screen)

Ok, there is probably an error message being output somewhere. If you try and sync from the Coder frame, you will get your errors output into the output panel at the bottom of the screen. If could try again and let me know if there is an error, please share the full traceback.

Sometimes, there is an error when git tries to clone the online repo and has trouble with incompatible filenames: If you get an error that git was unable to checkout the working tree, use a command prompt go to your directory holding the experiment, and use these commands:

inspect what was checked out with git status
and retry the checkout with git checkout -f HEAD

term has started today, so it may take a while to get back to this.

In the meantime I’ve managed to get the output of Psychopy 1.9.3 working after learning JavaScipt - so all’s good.

Ok good. The online capabilties of Psychopy 3 is much more developed that 1.90.3, so that is something to bear in mind. If you need further support, please let us know.