psychopy.org | Reference | Downloads | Github

noneType error when using parallelPort

OS (e.g. Win10): Win 10

PsychoPy version (e.g. 3.1.x): 3.1.2

**Standard Standalone? Yes

**What are you trying to achieve?: I tried to use parallel port to send triggers.

I’ve sucessfully used psychopy2 v1.90.3 to code my procedure and collect data, in which parallel were used to send trigger to BioPac.

Recently, I am going to collect new data, so I am trying to use the new version, i.e., psychopy v 3.1.2.

As previously, I code the script in Pycharm, so that I can test the script using either Psychopy3 v3.1.2 or Psychopy2 v1.90.3.

Then, I found that the script can not run because of the noneType error:

However, when I switched to Psychopy2 (v.1.90.3), it worked,

So, I guessed that it might be related to the update. I checked the Changelog and found that from v3.1.1, there was one note on parallel:

So I when to http://www.highrez.co.uk/downloads/inpout32/ and downloaded the latest version of inpout32.dll and inpout64.dll, and copied these two files to the folder where my script is. But still, I have the noneType error.

Any suggestions are appreciated. I know otherwise I have to switch back to Psychopy2.

Thanks in advance.

Hi, I have Windows 10, and do not have any issues loading the ParallelPort class using 32bit Python 3.6.7 (developers version), but I do have this issue when using the 64bit standalone PsychoPy and I see you have 64bit Python 3.6.6.

1 Like

Hi, David,
Thanks for your reply!
I do used the 64 bit standalone PsychoPy, seems that it is an common issue.
You reminded me to try the 32 bit version of PsychoPy v 3.1.2, now it works.