No words appearing on the experiment screen

OS (Mac OS Catalina V.10.15.7):
PsychoPy version (e.g. 2020.2.4):
**Standard Standalone
Cant get any text to appear when running an experiment.

This is really basic but no text is appearing when I run, a simple experiment with one field, the ‘hello world’ experiment in the User Manual.I have created a few new simple experiments and each time, just a blank grey screen appears with no text. In one experiment when I added a keyboard link, so that you could click out of the welcome message this appeared as an orange line not as a blue line.

I’ve gone through the instructions numerous times, and I am not inserting anything incorrectly or adding any complicated test. What is the problem here?

The following messages have appeared.

File “/Applications/”, line 221, in getKeys
name = event.getKeys(keyList, modifiers=False, timeStamped=False)
NameError: name ‘event’ is not defined

Experiment ended.

and this message has also appeared but still no text is appearing on the screen.

########### Running: /Users/ennadarcy/Desktop/Hello ###########

When I opened the PsychoPy application, a message came up on my mac stating that “The ‘git’ command requires the command line developer tools. Would you like to install the developer tools now?”

When I chose to install the software, the following message appears

“Cant install the software because it is not currently available from the software update server”. It still opens PsychoPy tho after this. Could this be a contributing factor?

Kind Regards,

Hi Enna,

Does the following fix your issue? Name error: name 'event' is not defined


Yes! Thank you, that worked!

Fantastic - please could you mark the solution for future users viewing this post? :slight_smile:


Hi guys, this is what fixed my problem.

“To fix this issue, you need to go to your System Preferences > Security & Privacy > Input Monitoring and allow PsychoPy3”.