psychopy.org | Reference | Downloads | Github

NameError: name 'pythonExec' is not defined

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): LinuxMint
PsychoPy version (e.g. 1.84.x): 3.2.2

What are you trying to achieve?: I want to make the experiment run.

What did you try to make it work?: I set up a experiment, but I can not execute it. I am not sure if it is there problem of path.

What specifically went wrong when you tried that?:
File “/home/vocabulary/anaconda3/envs/psypy3/lib/python3.6/site-packages/psychopy/app/builder/builder.py”, line 2188, in runFile
command = [pythonExec, ‘-u’, fullPath]
NameError: name ‘pythonExec’ is not defined

        command = [pythonExec, '-u', fullPath]

I know there is something wrong in the file of builder.py, but I don’t know how to figure it out.

I just wanted to say I got the same error after upgrading from v3.2 to v3.2.2 on Ubuntu today (using the zip file).
That’s too bad, since I struggled so long to get v3.2 up and running.
However, as a workaround I found I can compile the script in builder and then run it from coder.

Thanks, looks like the source code needs a quick update. If you are happy to fix yourself, you can change line 2188 in builder.py to:

command = [sys.executable, '-u', fullPath]

That’s weird. That was the final fix i made before the release so maybe I forgot to rebuild the zip file. Sorry. David’s fix is correct, which yo ucan see in this commit: