Psychopy encountered an unhandled internal error!

Hi, I’ve just downloaded Psychopy V3 and tried to run an experiment which was working perfectly on my old laptop some weeks ago (also V3 I believe!).

However now when I try to run it I get this error message: “Psychopy encountered an unhandled internal error! Please send the report under details to the developers”. (I’ve pasted the report below).

I don’t understand at all why this is happening, as previously the experiment was working fine. Strangely I can still run old experiments programmed in previous versions of PsychoPy.

Any help appreciated!

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\”, line 1066, in runFile
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 559, in runLocal
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\”, line 73, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\”, line 242, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\”, line 233, in _makeTarget
OSError: [Errno 22] Invalid argument

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10):
PsychoPy version (e.g. 1.84.x):
Standard Standalone? (y/n) If not then what?:
What are you trying to achieve?:

What did you try to make it work?:

What specifically went wrong when you tried that?:
Include pasted full error message if possible. “That didn’t work” is not enough information.

Hi There,

This looks like an error compiling the python script from your builder experiment.

Out of interest what happens if you try to run a previous version (experiment settings/cog image > Use version > select previous version) - does it run with the previous version you were using?


Thanks Becca for the interesting tip. I ran it through a previous version and it ran fine. Then I ran it through the latest version and it ran fine as well. How odd! Many thanks for your help!

how interesting! so long as you are happy you have a functioning experiment now ! - happy to help :slight_smile: