Movie stimulus does not play

Dear community,

I am new to psychopy and am building a short and simple experiment using video stimuli.
Unfortunately they do not work. You find deails and more information including the error message below.

I am very thankful for advice, I am sure, it is just a minor error, but I am stuck for hours and did not find the answer in the disscussion forum.

Best regards, Ines

OS (e.g. Win10): Win 10 pro
PsychoPy version (e.g. 1.84.x): v2021.2.3
Standard Standalone? (y/n) y If not then what?:
**What are you trying to achieve?:**Built a simple paradigm presenting movie stimuli (.mpeg)

**What did you try to make it work?:**vary the size, the path, the moviestim format (.mp4
, .mov)
What specifically went wrong when you tried that?:
The experiment starts, shows a grey screen and then stopps. When I included .png stimuli it worked finde.

Include pasted full error message if possible. “That didn’t work” is not enough information.

Exception ignored in: <bound method MovieStim3.del of <psychopy.visual.movie3.MovieStim3 object at 0x00000221B06B3A58>>
Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\visual\”, line 568, in del
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\visual\”, line 545, in _unload
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\visual\”, line 1270, in clearTextures
GL.glDeleteTextures(1, self._texID)
OSError: exception: access violation reading 0x0000000000000000

Experiment ended.
Experiment ended.

I’ve not tried playing movie stimuli directly, but this Reddit thread may be of interest. The top comment essentially says it could be a library error, so check the relevant library is updated.

Personally when I’ve implemented movies before, I’ve just had them playing on a separate window and had the experiment’s window open and close as appropriate. There we had video from a nature documentary playing as “background” to a musical experiment so it didn’t really matter that we couldn’t pause it. Crude but effective.

Many thanks for your reply. It was a simple format error. Once I converted mpeg into mp4 it worked.

Kind regards, Ines

1 Like