psychopy.org | Reference | Downloads | Github

Mouse component not responsive

URL of experiment: https://pavlovia.org/run/Marta_G/stroop_task/html/

Description of the problem:

Version being used: 2020.1.3

This is a standard stroop task except I want my participants to use touchpad/mouse to select their answer from four possible options displayed on the screen. The mouse component works perfectly when I run this locally i.e. I have specified that the routine should end with ‘a valid click’, saved mouse state to ‘on click’, new clicks only box has been ticked off, and clickable stimuli selected (in my case: txt_blue, txt_green, txt_red, txt_yellow).

When I run it online, the cursor is visible however by clicking on my clickable stimuli (blue, red, green, yellow) nothing happens i.e. can’t proceed onto the next trial…

I have tried ending the routine with ‘any click’ to see if I can force the next trial and that works but obviously in this particular experiment I need to my participants to click on one out of four words which should force the next trial.

I have also tried renaming my stimuli headings, re-shuffling the order of components
Any ideas how I can resolve this issue please?

For those who might have encountered a similar problem, you may want to try inserting an additional element to your routine i.e. a polygon so that it overlaps on screen with each of your clickable stimuli. In settings you can control for each polygon’s location, size and shape. Initially maybe make it visible by setting Opacity$ to 1 to make sure it sits where it’s supposed to sit. Once happy with all its parameters change it to opaque (delete 1 & insert 0). As for the mouse element, set your End routine to ‘valid click’, Save mouse state to ‘on click’, time relative to ‘mouse onset’, clickable stimuli - here list the names of your polygon(s) without using inverted comas and separated by them with comas. That way it runs online no problem. Just be mindful that in the output sheet participants’ answers will be coded as the names of your polygon(s) but that’s no big deal really as long as they are being captured!