psychopy.org | Reference | Downloads | Github

Issues running PsychoPy in Ubuntu 16.04

Hello

I am having problems running PsychoPy in Ubuntu 16.04

I have installed it using pip install psychophy as indicated here. When I first tried to run psychopy, I got the error ModuleNotFoundError: No module named 'wx' I wasn’t sure which was the right wxPython wheel for my platform, so I run this command which seemed to fix the issue

pip install -U     -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-16.04     wxPython

However, when I now try to run psychophy I only see for a very brief moment the splash screen, then the program fail to launch. In the terminal I see the following:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

but no obvious error message apart from that. I am new to PsychoPy, and still not very familiar with python in general, so I suspect I missed something simple.

Any suggestions about what could be the problem here?

Thanks!


Some other info:

$ psychopy -v
PsychoPy3, version 2020.1.2 (c)Jonathan Peirce 2018, GNU GPL license
$ pip --version
pip 20.0.2 from /home/matteo/anaconda3/lib/python3.6/site-packages/pip (python 3.6)
$ python --version
Python 3.6.4 :: Anaconda, Inc.

Hi,
not sure about ubuntu, but since you use anaconda, you can install wxpython from conda-forge repository.
conda install -c conda-forge wxpython

Does your system fulfill all prerequisites, e.g. freeglut? Like here: https://stackoverflow.com/a/43945197 but without all the dev-packages (you don’t want to compile yourself)