psychopy.org | Reference | Downloads | Github

Issue with routine containing Image component

I have built an experiment using builder. I am using images and excel files. Both of these are in the resources folder and both work in a number of the routines within the experiment.

My problem is that, for some reason, one of my routines doesn’t work.

The duration of my stimuli are drawn from the excel file and they work on the audio and text components. Similarly, the images are loaded and work fine on my ‘adaptation’ and ‘top-up’ routines. However, on my ‘test’ routine which uses the same excel file to set the duration for the image to displayed for and the same image path for my image, the online experiment goes to a blank screen and can only be exited using Esc.

Does anyone know why this might be happening?

I have tried replacing the ‘test’ routine completely and have also tried using a specific duration rather than variable duration and the issue persists.

Here is a picture of the Flow in builder. I have circled the problematic routine:

Thanks for any help.