Gazepoint and PsychoPy 2024.1.5

Dear all,

This also applies to builder. I tried to get one of our Gazepoint HD eye trackers to work in Psychopy, and created a minimal builder example, with only the calibration, and also tested the coder example (without modifications) at Gazepoint — PsychoPy v2024.1.5 . The error messages are similar (see below).
I have found references to problems with the gazepoint eye tracker in earlier recent versions of PsychoPy, but this is mentioned in the bug fixes for 2024.1.5 " * Failing to find Eyetracker Components […] and Gazepoint by @mdcutone in #6424 )" - so I hoped it was fixed.

The traceback is as follows:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\client_init_.py”, line 1089, in addDeviceView
dev_import_result = import_device(dev_mod_pth, dev_cls_name)
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\devices_init
.py", line 944, in import_device
event_class = getattr(event_module, event_class_name)
AttributeError: module ‘psychopy.iohub.devices.eyetracker.hw.gazepoint.gp3’ has no attribute ‘GazepointSampleEvent’
Traceback (most recent call last):
File “[…]ento_2_coder.py”, line 10, in
tracker = io.devices.tracker
AttributeError: ‘ioHubDevices’ object has no attribute ‘tracker’

In case it matters, I am running on Windows 11 - always with the Gazepoint control software running.

There is one detail - I had earlier versions of PsychoPy, which I deleted (through the installer) to install 2024.1.5 without conflicts. The Gazepoint Eyetracker Support plugin was installed without any intervention - the uninstall apparently did not affect that. I wonder if it needs updating, but there is no option to do so, apparently. I can find the ‘missing event’ in the supported_config_settings.yaml file on the gazepoint module github page (psychopy-eyetracker-gazepoint/psychopy_eyetracker_gazepoint/gazepoint/gp3/supported_config_settings.yaml at main · psychopy/psychopy-eyetracker-gazepoint · GitHub) but I cannot find this yaml file in my own local installation.

It looks like a configuration problem but how do I fix it?

I appreciate any help.

1 Like

Just want to add that we have the same error, with the same Psychopy version, a GazePoint-3 eyetracker, also on Windows 11.