psychopy.org | Reference | Downloads | Github

Feature request: Disable zooming (OSX)

I find that while editing, I’m often scrolling (two-finger trackpad gesture) and copying text. Which means that its not unusual for my finger to accidentally rest on the command key while I’m doing a two-finger scroll. Unfortunately, this causes the text to zoom in and out (from microscopic to gigantic). I’d like a way to disable this feature, as I (1) could never see myself using it (command+ and command- are the OSX tradition), and (2) I find it extremely annoying.

Yes, please disable gesture zooming in OSX. It drives everyone in my lab nuts. Its so bad, that we do most of our development in Spyder, and only use Psychopy Coder for testing towards the end of development.

Drrrtt. Didn’t realize I was replying to myself. Eitherway, the zooming drives us nuts.

Hi @Matt, would you like to raise an issue on the PsychoPy GitHub repository? See https://github.com/psychopy/psychopy

I know what you mean - I also do this occasionally. The zooming is a default thing of ScintillaTextCtrl. I don’t know off the top of my head how to do that though, and there are more important things for me to be working on right now, but I’m happy to take a pull request that makes this work from Ctrl-+ and Ctrl–

At least that points me in the right direction. If I get frustrated enough, maybe I’ll dig into the source code and see how this can be disabled/modified.

-Matt

Haha, yes, it’s all about if we get frustrated enough. :slight_smile: