psychopy.org | Reference | Downloads | Github

Fail reading conditions file

Nothing happens when I select a conditions file. In the properties dialog, I do get a file selector and it allows me to browse to my xlsx or csv files, but when I select them, nothing happens.

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 1.90.2
Standard Standalone? (y/n) If not then what?: y
**What are you trying to achieve?: import conditions file

**What did you try to make it work?: tried several xlsx and csv files

**What specifically went wrong when you tried that?: nothing happened, Psychopy did not pick up the file

I’ve found that, very rarely, loops can get into a sort of toxic state. Try deleting the the loop, inserting a new one, and trying again.

Thanks for your response. Unfortunately, does not work.
I should mention that I’ve just installed Psychopy and this is the first thing I try so this never worked before.

Hi Michael, I’m having the exact same problem. I’ve tried .xlsx and .csv but neither are working. When I hit the browse button next to “conditions,” I can see my files and click on them, but then nothing happens. The conditions area remains blank. I’ve also tried typing the file name in directly and hitting “okay,” but when I open the properties window back up again it just says, “No parameters set (conditionsFile not found).” It’s my first time using psychopy and I downloaded the most recent version today. Do you have any other ideas? Thanks!

Other things I’ve tried:
-Deleting the loop and making a new one
-Closing the program and reopening it
-Adjusting the .xlsx file info to open with psychopy
-Adjusting the file so that it’s read/write and fully accessible
-Resaving the file

FYI: I’m using a macOS Sierra Version 10.12.6
I originally created the file in “numbers” and exported it to .xlsx and .csv

Update: I figured it out! It turned out that I had a default header, “Table 1” in my excel that I guess psychopy didn’t understand or was reading as a blank cell.

I have the same problem here. I have just created an condition file in excel. I cannot add it into the conditions either through browse or type in the path and name. I can only add the conditions though creating a pkl file. This is on my pc and I have a pretty new version of excel (don’t know if it’s the problem).

Then I created an excel file exactly the same way in my mac. And tried to add this file into conditions in my pc. And it worked.

I cannot see any differences between these two excel files. But the one I created on my pc just didn’t work.

Save them as .csv and open in a plain text editor, where you can see invisible characters.

It is very difficult to spot problems in Excel spreadsheets as it hides things from you: e.g. you can’t tell the difference between an empty cell and a cell containing a space character.

So can be much safer to work with a plain text format like .csv

Thanks Michael!
I did what you suggested and found some unexpected " in the csv file.

Thanks for the responses. That way, I knew the Excel file was the place to look. I did not find anything unusual but just created a new Excel file and filled in the same data, and then it automagically worked…

1 Like