psychopy.org | Reference | Downloads | Github

Experiment won't run, PTB error given

If this template helps then use it. If not then just delete and start from scratch.

OS: Win10
PsychoPy version: v2020.1.3
Standard Standalone? (y/n): y
What are you trying to achieve?: An experiment in which there is a randomized sequence of blue and orange circles that go from size X to size Y upon key press.

What did you try to make it work?: Used builder to insert a polygon with 0 vertices, size X, and colour blue. Then added a keypress to end the routine. Added a new circle with size Y and colour blue.

What specifically went wrong when you tried that?:
0.3824 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pysoundcard’, ‘pygame’] (in that order).
3.3595 WARNING User requested fullscreen with size [1024 768], but screen is actually [1920, 1080]. Using actual size

Very new to PsychoPy. I apologize for the vague descriptions, trying to learn. I don’t get these errors when I try the tutorial of stroop effect on youtube. I changed the experiment preferences to PTB to no avail. Not sure what to do! Want to figure this out before moving on and finishing everything.

1 Like

For me, changing the order or audio libraries got rid of that error message:
In PychoPy3>Preferences>Hardware I changed from [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’, ] to [‘PTB’, ‘sounddevice’, ‘pyo’, ‘pygame’, ].

Does that help?

1 Like