Experiment with editable text box crashes firefox

OS (e.g. Win10): Mac OSX 10.15.7 Catalina
PsychoPy version (e.g. 1.84.x): 2021.2.3
Standard Standalone? (y/n) If not then what?: y

Hello all,

I’ve created an editable text box element for a few questions in my experiment (first time with version 2021.2.3), but when I run the experiment online, my browser crashes at the onset of the text box element. If I remove this routine, it runs fine until the next editable text box appears. If I change the start time of the textbox component in the routine, the crash is also delayed by the same amount.

As can be seen above, I have set it to every repeat, made it editable, and put a space for the text as indicated elsewhere (e.g. here).
Units are set to height, as indicated here.
I have tried adding freeRecallResp.refresh() in a code component at the beginning of the routine as indicated here.
The experiment runs in builder.

Since my browser crashes immediately when encountering the textbox online, I’m unsure where to find a traceback of the error. Has anyone encountered this? Any suggestions?

Is there an error message in the browser developer console?

Hi @wakecarter, unfortunately the entire browser crashes (the window disappears, replaced with a popup “Mozilla Crash Reporter”) so I’m not able to take a look in developer console. After bit of sleuthing I discovered I can retrieve the crash report-- which I won’t post in full here because it might contain sensitive information, but this part seemed relevant:

  "num_records": 2,
  "records": [
      "message": "abort() called",
      "module": "/usr/lib/system/libsystem_c.dylib"
      "module": "/System/Library/PrivateFrameworks/GPUSupport.framework/Versions/A/Libraries/libGPUSupportMercury.dylib",
      "signature_string": "Graphics kernel error: 0xfffffffb\n"

Not sure if that helps. If you want to take a look at the full thing, perhaps I can message you privately?

Update: I got my hands on another computer, which seems to run the experiment fine. So I think this is a local issue. Still no idea what caused it though.