Experiment timing differs when older script is reuploaded

URL of experiment: Pavlovia

Description of the problem: Since a couple of days I have been having difficulties when trying to modify a previous experiment for a new paradigm. Although I get no error, sometimes I notice that the display (which contains a certain number of polygons) seems to be partially not refreshed relative to the previous trial.
So I tried to go back to the older experiment uploaded on pavlovia, but I do not see the error there.
Since I suspected something was being messed up when the experiment is re-compiled, I downloaded the old script (from before Christmas) to a new folder, opened it with psychopy, re-uploaded it as a new experiment and piloted it again.
Now, if I pilot the two experiments, which in principle are the same script, they behave differently, besides the updating problem, the stimulus duration seems to be much shorter. I am sort of suspecting that maybe the issue is in the timing of the stimulus onset (which is coded in the script as follows


If that is sometimes anticipated with respect to the piece of code that defines how it should be (like if it would be negative or something), it could explain why the stimuli inherit the parameters from the previous trial.

Has anybody encountered any similar problems with scripts that used to work or knows whether there´s been any change to the way the timing is supposed to work?

Thank you in advance,


If anybody encounters this, it turns out the problem was due to a change in the handling of opacity in the newer versions of psychopy (where if the level of opacity is defined for some objects on a trial by trial basis, sometimes it is not updated). It appears to be a known bug. For now I solved it going back to version 2020.1.3.

1 Like