Experiment stuck on 'initialising' - how can I bugfix?

URL of experiment: prolificauto [PsychoPy]

Description of the problem: I edited an experiment which previously worked online, but now gets stuck at “initialising” - i have seen it mentioned that in the console you should be able to see the errors/what lines of code are causing the error, but when I look at the console for this experiment the errors seem uninformative - any advice here would be appreciated.


I’ve just looked at your console and the error message Failed to load resource: the server responded with a status of 404 () is because you are using an html folder and probably a 2021 version of PsychoPy

This post might help

Thanks! Deleting the HTML folder and swapping the experiment settings fixed the getting stuck an initialising. Now I’m getting this error, im assuming because I just changed how images are set up in the files for the experiment:


The images are stored with the following structure:

experimentfile > resources > images > [image files to be used in the experiment]

In the code chunk which loads the images, the path specified is images/Fire_truck_front.gif (specified in the same way for other images). I tried deleting the resources folder and just having the images folder, but that resulted in the same error. Do you have an idea of how to fix this?


Attach the resource via Experiment Settings / Online / Additional Resources

Thanks, I tried adding the images to additional resources, but the same error message as above is still there. Screenshots below show the current state, I have tried changing the code chunk to match the path as written in the “additional resources” box, and redoing it but just having the images folder (not inside the resources folder) - but all of these versions return the same error. Is there something I’m missing here about how to refer to the images when loaded in via additional resources?



In your screenshots you have attached images from resources\images but then try to load them from just images. Are those from different attempts?

To run the latest code online you need to refresh the Browser (Ctrl-Shift-R) or use an incognito tab.

Apologies, yes, those were from different versions; these show the setup from the same version which also produces the error. I also tried refreshing/running it incognito, both times it returns the same resource error.



What version of PsychoPy are you using? Has this repository ever had an html folder?

I’m using 2021.2.3 - yes, it had an HTML folder, i removed it following the instructions from your steps in the post linked above