psychopy.org | Reference | Downloads | Github

Experiment screen no longer correct - seems as though resolution or graphics have somehow failed?


#1

Hello,

I have an experiment in PsychoPy that has been working beautifully since June. Yesterday it suddenly stopped. I noticed with my last participant yesterday that the screen looked too small - meaning the directions seemed to have scaled down leaving a lot more gray space on the perimeter. I opened it today, and the screen is now completely wrong. I can no longer read any of the directions, and the pictures and slider bars have changed and are not useable. If I try to click on them, PsychoPy shuts down.

Here is the message I’m getting:

I did try changing the monitor to 1920, 1080 in the monitor settings screen, but it makes no difference to the look of the screen, or the error message at all. I am using a Lenovo Yoga 3 with Windows 8.1 and PsychoPy version 1.90.2.

Any suggestions would be greatly appreciated.

Thank you.


#2

Try updating your video drivers, those errors seem to be associated with driver support issues.


#3

Thank you very much for your quick response.

I updated the drivers. Nothing changed in the problems with the way the screen looks, but now my output says this:


#4

I have discovered the problem. It is Skype. If you have an older version of Windows, do not update your Skype. It will wreak havoc with your video driver - which then messes up PsychoPy.


#5

Ok, machine is fixed and all drivers updated according to tech. He put Windows 10 on my computer. I uninstalled and reinstalled v1.90.3. However, I’m still having the exact same problem, and getting the exact same error message.

FYI I have intel® HD graphics 5500

Also FYI, based on a previous post, I downloaded a GL Viewer and tested my Laptop. I got these results:

I need to get this up and running again by Monday. All help and suggestions are greatly appreciated. From everything I’ve read, I cannot figure out why PsychoPy is not running. I think I have all the system requirements…I think…

Thanks!


#6

This appears to be an issue with the Intel Graphics driver. PsychoPy is using features from OpenGL 2.0 and Intel might not be supporting those features in their driver.


#7

Ok, so what should I do? I thought as long as I had 2.0 or better I was ok. Should I roll back the driver? I’ve never done that. How do I tell which one I need? Thanks!

FYI Matthew, I should have posted from the getgo that I am a complete novice at all of this. I am just barely learning to use builder in PsychoPy, and know absolutely nothing about driver’s etc. Everything I’ve tried so far is from searching PsychoPy Discourse and internet extensively for suggestions/answers. I also tried calling Lenovo support, but they wouldn’t help me without mucho dinero. So, in other words, I need a lot more information than your normal PsychoPy discourse poster in order to know what to do. I greatly apologize for the inconvenience.

Thanks again!


#8

Don’t rely on Windows to update the driver. Go to the Intel site itself and download and install the latest driver for that specific model yourself.


#9

Based on the output provided, it appears the driver installed supports OpenGL 3.0+ which means some version of the official driver is likely being used. So I think everything was done right and the error results from the lack of support (or bugs?) provided by the official driver. There might be a newer driver which fixes these issues available so try that out.

Try it out if upgrading the driver via Intel doesn’t work. It’s clear a previous configuration worked so a rollback might be in order.


#10

FYI just for anyone else that has this problem, my driver is the most updated driver from intel itself - not windows. So, the newest driver from generation 5 chip is apparently not supporting OpenGL

I will rollback. As soon as I figure out which rollback to go to (the list is huge), I will post the one that worked here. I’ve also contacted Intel about this.

Thanks.


#11

Ok, I can’t get it to work. I’ve spent hours on the phone with Intel, and they can’t find a driver that will make PsychoPy work again. I called the manufacturer of the computer (Lenovo) and they only service machines in the US and Canada - I’m in the UK, so they wouldn’t help me. I’m trying desperately not to do a factory reset because I will permanently lose some things. Could it be something other than the driver?

Thanks!


#12

I’m out of ideas. Usually, this pattern of errors is caused by something driver related since it worked then suddenly doesn’t without any changes to PsychoPy. It used to be that the driver being out-of-date caused these issues, now it seems like new drivers might be breaking things.

I have a machine with a similar chipset. I might be able to come up with a solution if I also encounter the same problem. However, we can’t rule out it could be an issue with a library PsychoPy uses.


#13

I kind of have it fixed!

There is still an issue, but at least it is running now.

I did a system restore (which didn’t fix it), then I uninstalled Skype, then did a PC search for Skype and deleted everything that had anything to do with Skype. I then did the same for PsychoPy. Then I reupdated to Windows 10. I again searched for Skype and deleted anything that got added. Finally, I reinstalled PsychoPy. It is running, but now I get this error:

I did a search on vertical blank, and the card is set to sync with vertical blank.

So, here is what I get when I run the sysinfo demo in PsychoPy:
Welcome to PsychoPy2!
v1.90.2

Problem compiling: [Errno 13] Permission denied: ‘C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\sysInfo.pyc’

Running: C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\sysInfo.py

Paths to files on the system:
userPrefsFile: C:\Users\suileangorm\AppData\Roaming\psychopy2\userPrefs.cfg
appDataFile: C:\Users\suileangorm\AppData\Roaming\psychopy2\appData.cfg
demos: C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos
appFile: C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\PsychoPy.py

System info:
Windows-10-10.0.17134

Python info
C:\Program Files (x86)\PsychoPy2\pythonw.exe
2.7.11 (v2.7.11:6d1b6a68f775, Dec 5 2015, 20:32:19) [MSC v.1500 32 bit (Intel)]
numpy 1.13.0
scipy 0.19.0
matplotlib 2.0.2
pyglet 1.2.2
pyo version 0.8.7 (uses single precision)
pyo 0.8.7

PsychoPy 1.90.2
have shaders: True

OpenGL info:
vendor: Intel
rendering engine: Intel® HD Graphics 5500
OpenGL version: 4.4.0 - Build 20.19.15.4642
(Selected) Extensions:
True GL_ARB_multitexture
True GL_EXT_framebuffer_object
True GL_ARB_fragment_program
True GL_ARB_shader_objects
True GL_ARB_vertex_shader
True GL_ARB_texture_non_power_of_two
True GL_ARB_texture_float
False GL_STEREO
max vertices in vertex array: 1048576
3.5668 WARNING Monitor specification not found. Creating a temporary one…

I can also send you the configuration report from the reinstall if that would help.

I’m reluctant to try poking around myself after 7 days without PsychoPy capability. So, any suggestions of what to try now would be greatly appreciated.

Should I try updating the drivers again? I’m pretty sure I’m back to just a windows driver, and not the ones from Lenovo or Intel.

Thanks so much for all your help with this.


#14

Hello,

Thanks for tracking down the source of the issue. I would have never thought Skype would be causing problems here, we certainly need to look into it more. I would recommend keeping your drivers as current as possible, hopefully, that will be the end of that.

  • mdc

#15

I apologize. I knew it was Skype (post #3). That info gets lost after many posts. Let me know if I need to point that up for others.

Ok, so you think an update on the drivers would fix the error I’m getting now? Is that what you are saying? Because I’m still having issues. The screen is still not viewing as it should, but it’s at least workable now. Here are the errors again:


#16

I would try to update the drivers now to see if it will resolve those issues. But it looks like your current GL driver has the capabilities required for running PsychoPy based on the previous output you posted, which means it’s not the default Windows driver. Unstable framerates could have various causes, such as background processes hogging up resources (windows update), so it might not be as simple as a driver update.


#17

Updating from the Lenovo site didn’t help. I’m still getting the same error messages above.

What about the fact that my monitor specification is not found?