Experiment does not run on my iPad but does on another

URL of experiment:

Description of the problem:

I have several experiments that run perfectly online using my PC but when I try and run them on my iPad it fails. I get the following error. “Unspecified JavaScript error”. It does not even let me enter the participant number. The VERY strange thing is that my daughter can run it on her iPad. I have tried it on my 8th generation and my 2nd generation iPads with the same result. She runs it on her 6th generation and it works fine.
I have systematically stripped parts of the experiment to see if I can see what is causing the problem. I have got to the point where there is only a line of text displayed and it still fails. It must be something to do with the HTML files but I do not know what it could possibly be.
I created a brand new experiment with only the same line of text and it runs fine. In that case it does not generate an HTML folder.
I am at a loss as to what could possibly be causing this problem. My experiments are ready to be used in trails but cannot until this is resolved.
I have looked into ways of debugging on the iPad but they look quite complex.
Any suggestions would be greatly appreciated. I can provide access to the experiment if it helps.

regards Phil

I have tried this with safari and chrome with the Sam result.

My daughter has now reported that it has stopped working for her using safari but still works with chrome.


did you enable JavaScript on your iPad (Settings - Safari - Advanced - JavaScript)?

Best wishes Jens

Hi Jens,

Thanks for your reply.
Yes, it is turned on. It was one of the first things I checked.


I ran the Chromium javascript console logger on my ipad and got the following log. It looks like it loads the resources and then gets an error.

DEBUGDEBUG unknown | signal: {“message”:“DOWNLOADING_RESOURCE”,“resource”:“sounds/SoundSRE21aLetsTrySomeMore.wav”}

DEBUGDEBUG unknown | signal: {“message”:“DOWNLOADING_RESOURCE”,“resource”:“sounds/arrow.wav”}


ERRORFATAL unknown | null

DEBUGDEBUG unknown | signal: {“message”:“RESOURCE_DOWNLOADED”,“resource”:“AllEncodingPractice.xlsx”}

DEBUGDEBUG unknown | signal: {“message”:“DOWNLOADING_RESOURCE”,“resource”:“SampleM.jpg”}


ERRORFATAL unknown | null